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Chapter 2: User Interface 

Overview 

Creating and customizing the look of your forms can be accomplished 
through FormPort Designer’s graphical WYSIWYG interface. The tools, 
concepts and functionality of the FormPort Designer interface should be 
very familiar to people who have used traditional object-oriented drawing 
programs such as Visio, CorelDRAW! and Adobe Illustrator. 

 

In addition to the standard Windows drop-down menus, some of the more 
common functions also have graphical icons and keyboard shortcuts—all 
of which will be discussed throughout this chapter. 

A complete list of all icons and shortcut keys can be found in Appendix A: 
Keyboard Shortcuts. 
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File Menu 

The File menu contains the following commands: 

New 

This command instructs FormPort Designer to create a new, empty 
document. New can be initiated through the File menu, or the following 
icon or keyboard shortcut: 

 OR 
 

Open… 

This command opens a document that has previously been saved. Open 
can be initiated through the File menu, or the following icon or keyboard 
shortcut: 

 OR 
 

Once selected, a File Open Dialog window appears and displays a list of 
files in the current directory. If you wish to load another file from 
elsewhere, indicate the correct path. 

Open Dialog 

To load a document, select it from the list or enter the name of the files in 
the File Name field and then click on the Open button. 

 

To cancel this operation, simply click on the Cancel button. 
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Close 

This command closes the active document.  

If the current document is new, or has changed since it was first opened, 
you’ll receive a prompt asking if you’d like to save the document before 
closing.  

NOTE: Closing a document without saving will result in all changes made 
since it was opened or created to be lost. 

Save 

Saves the active document. Use this command to save the latest changes 
of the active document onto the hard disk. 

Selecting this command will open up the Save As... dialog, and ask for a 
document file name if one has not been entered before. Save can be 
initiated through the File menu, or the following icon or keyboard 
shortcut: 

 OR 

Save As Dialog 

If the document hasn’t been saved yet, this dialog will automatically open 
and prompt for a filename and path to save the file. Click on the Save 
button to accept the name and path you’ve chosen. 

 

To cancel this operation, simply click on the Cancel button in this dialog. 
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Save As...  

Saves the active document with a new name. Use this command to save 
the active document with a new name on the hard disk. Selecting this 
command will open the Save As... dialog. 

Compile Document...  

After a form has been created, this command compiles the document and 
saves it in the *.fpf file format. Selecting this option will open the 
Compile dialog. If a name for the compile file hasn’t been previously 
entered, you must now provide one. 

The Compile command can also be initiated by clicking on  located on 
the Standard toolbar. Any changes to the document are saved at this point. 
If the document has not yet been saved, the Save As… dialog appears 
and requests one. 

Compile Dialog 

This dialog opens automatically the first time you compile a document. 
The compile name must be entered in the File Name field, and then 
selecting Save will place the compiled file at the desired location. 

NOTE: Your document must be saved before it can be compiled. If it 
hasn’t been saved, FormPort Designer will prompt you before compiling. 

 

To halt the compile operation, simply click on the Cancel button. 
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Compile Document As...  

This command compiles the active document to a *.fpf file—but with a 
new name. 

Selecting this command will automatically save the last unsaved changes 
of the active document, and will cause the Save As... Dialog to open (if 
the document have not been saved before). 

Import Document...  

Imports a compiled document into the program. Use this command if you 
wish to insert a previously-compiled *.mff or *.fpf file into the active 
document. 

Selecting this command will open up the Import dialog and ask for the 
name and path of the file you wish to import. 
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Import Dialog 

This dialog opens when the Import Document... command is selected 
from the File menu. Choose the desired *.mff or *.fpf file (indicating 
another path, if necessary) and click on Open to load the file into the 
active document. 

 

Click on Cancel if you wish to halt this operation. 

Document Information...  

Choosing this command displays a screen that lists all pages in the active 
document as well as the components contained therein. 
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This screen is for information purposes only, and cannot be altered 
directly. Click on the Close button when finished. 

Document Setup...  

Choosing this command displays the active document setup screen, as 
shown in the figure below: 

 

This property sheet contains the following tabs: Printer Information, 
Document Information, Document Validation and Global Page 
Calculation. Information in this section is used during form creation and 
printing. 

Print Preview  

Selecting this command or icon  displays an approximation of how 
your form will look once it’s printed. Since the output of different models 
of printers can vary, you need to define a Printer Type in the Printer 
Information Property Page (located in Document Setup). 

Also, documents must be saved and compiled before they can be 
previewed. If neither of these has been done recently, and there are 
unsaved changes, a dialog box will appear and prompt you to do both. 
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NOTE: This feature can be disabled through the Tools Options menu. 

Print...  

This command sends the active document to the printer, utilizing the 
settings specified through Page Page Setup.  

Print can be initiated through the File menu, or the following icon and 
keyboard shortcut: 

 OR 

Send Mail  

Sends the active document through electronic mail as an attachment. 

Selecting this command will open up the Choose Profile dialog, asking 
to select the correct profile for sending your mail. 

 

Exit  

Closes the FormPort Designer application. If there are any unsaved 
changes in any of the open documents, a Save As… dialog will appear 
and prompt you to save. 

To save, enter a file name and click on the Save button. Otherwise, 
choose Cancel and the application will close without saving any open 
documents. 
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Edit Menu 

From the Edit menu, you can perform common Windows functions such 
as editing text objects, importing library files and defining object 
properties. Every feature of the Edit menu is described in the following 
section.  

Undo  

Use this command to go back in time and undo the last action you 
performed. Continuing to select this command will keep undoing previous 
actions. By default, FormPort Designer has 15 undo levels, but can have 
as many as 50. However, increasing the number of undo levels could 
impact system performance, and should be used with caution. Undo levels 
can be adjusted by selecting Tools Options. 

The Undo command can be initiated through the Edit menu, or the 
following icon and keyboard shortcut: 

 OR 
 

Redo  

In the event you’ve chosen Undo too many times, Redo allows you to 
step forward through all the undone steps. 

Redo can be initiated through the Edit menu, or the following icon and 
keyboard shortcut: 

 OR 
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Cut 

Places a copy of the selected item into memory and then deletes the 
original. Performing this action will replace previously-cut or copied data 
that’s currently stored in memory. 

Cut can be initiated through the Edit menu, or the following icon and 
keyboard shortcut: 

 OR 
 

Copy  

Puts a copy of the selected object into memory. This differs from the Cut 
command because the original object remains intact. Copying an object 
will replace previously-cut or copied data stored in memory. 

Copy can be initiated through the Edit menu, or the following icon and 
keyboard shortcut: 

 OR 
 

Paste  

This command places a copy of the item stored in the clipboard (placed 
there by using either the Cut or Copy command) into the current page. If 
there is no object stored in memory, this command will be grayed-out. 

Paste can be initiated through the Edit menu, or the following icon and 
keyboard shortcut: 

 OR 
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Delete  

Deletes the current selection. Use this command to delete the selected 
objects from the active page. Once deleted, an object can only be restored 
by choosing Undo. 

Deletions can be implemented through the Edit menu of by pressing the 
Delete key. 

 

Edit Text  

This command places text objects into edit mode. When adding a Rich 
Text object, for instance, you would enter this mode to define the text and 
apply basic formatting such as font type, size, attributes and color.  

NOTE: You must select a text object in order for this command to be 
available. 

Select All  

This command selects all the drawing objects available in the active page. 

Select All can be initiated through the Edit menu or the following 
keyboard shortcut: 
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Filter Selection… 

This command allows you to select specific types of objects within your 
document. Choosing Edit Filter Selection… displays the following 
dialog: 

 

Simply check the types of object you wish to select and click on OK. 

Library / Import  

This command loads previously-saved library objects from the disk. 

Choosing this command will open up the Import Components From 
Library dialog asking to enter the needed information for the components. 

Library / Export  

This command saves the selected components to the hard disk. 

Choosing this command will open up the Export Components To 
Library dialog asking to enter the needed information for the components. 
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Properties...  

This command displays the properties related to the currently-selected 
object. When chosen, it opens the associated property sheet of the 
component. 

The property sheet can be launched by double-clicking on the drawing 
object or through the following icon, keyboard shortcut and action: 

 OR 
 

Default Properties...  

Displays the default properties of the active document. These settings are 
used whenever a new object is created. 

Selecting this command opens the Default Properties property sheet 
containing the following pages: Line Property Page, Fill Property Page, 
Font Property Page, Round Corners Property Page. 
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View Menu 

The View Menu allows you to display or hide system toolbars, which 
provide convenient, single-click access to common functions. 

Toolbar Standard Bar  

This command either displays or hides the Standard Toolbar, as shown in 
the following figure: 

 

Here is a complete list of buttons available in the Standard Toolbar: 

Click To 

 
New. Creates an empty new document.  

 
Open. Opens an existing document.  

 
Save. Saves the active document to the hard disk.  

 
Compile. Compiles the active document to the *.fpf file 
format.  

 
Cut. Removes selected component(s) from the active 
document and copies them to the Clipboard. This button is 
only enabled if there is at least one selected component. 

 
Copy. Copies the selected component(s) of the active 
document to the Clipboard. This button is only enabled if 
there is at least one component selected. 

 
Paste. Inserts a copy of the components(s) stored in the 
clipboard into the active document.  

 
Print Preview. Displays an approximation (based on printer 
selection and settings) of how the document will appear 
once it’s printed.  

 
Print. Sends the active document to the printer.  

 
About. Displays the About dialog, containing information 
about the application and vendor.  

 
Help. Activates context-sensitive help.  



 
                 Chapter 2: User Interface 

Capella Technologies, Inc.                                                                                                           29

Toolbar Align Bar  

Shows or hides the alignment buttons toolbar, as displayed below: 

 

The buttons on the Alignment toolbar will only be enabled if there is more 
than one component selected on the active document. 

Here is a complete list of buttons available in the Alignment Toolbar: 

Click To 

 
Align Top. Moves the selected objects so that the topmost 
edges are aligned.  

 
Align Middle. Moves the selected objects so their center 
areas are aligned vertically.  

 
Align Bottom. Moves the selected objects so that the 
bottommost edges are aligned.  

 
Align Left. Moves the selected objects so that their leftmost 
edges are aligned.  

 
Align Center. Moves the selected objects so their center 
areas are aligned horizontally. 

 
Align Right. Moves the selected objects so that their 
rightmost edges are aligned. 

Toolbar Canvas Bar  

Shows or hides the canvas buttons toolbar, as displayed below: 

 

Here is a complete list of buttons available in the Canvas Toolbar: 

Click To 

 
Undo. Undoes the last change or action performed on a 
component.  

 
Redo. Steps forward through undone actions.  

 
Toggle Grid. Shows or hides the user-defined grid.  

 
Snap to Grid. Enables or disables grid snap.  
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Toolbar Drawing Bar  

Shows or hides the drawing buttons toolbar, as displayed below: 

 

Below is a complete list of buttons available in the Drawing Toolbar: 

Click To 

 
Select. Selects components for editing or manipulation. 

 
Rich Text. Inserts a Rich Text object. 

 
Line. Allows the user to draw a line on the document.  

 
Ellipse. Adds a user-definable oval object. 

 
Round Rectangle. Inserts a rectangle with rounded corners 
into the document.  

 
Rectangle. Adds a rectangle object. 

 
Image. Imports an external bitmap image and places it in the 
document. 

 
Barcode. Places a barcode in the document. 

 
Field. Inserts field text object. 

 
Spool Barcode. Places spool barcode data. This button will 
only be enabled if a spool file is currently loaded.  

 
Spool Image. Places spool image data. This button will only 
be enabled if a spool file is currently loaded.  

 
Spool Text. Places spool text data. This button will only be 
enabled if a spool file is currently loaded. 

 
CSV Spool Barcode. Places CSV barcode data. This button 
will only be enabled if a spool CSV file is currently loaded. 

 
CSV Spool Image. Places CSV image data. This button will 
only be enabled if a spool CSV file is currently loaded. 

 
CSV Spool Text. Places CSV text data. This button will only 
be enabled if a spool CSV file is currently loaded. 
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Toolbar Layout Bar  

Shows or hides the layout buttons toolbar, as displayed below: 

 

NOTE: The buttons on this toolbar will only be enabled if there is more 
than one component selected on the active document. 

Here is a complete list of buttons available in the Layout Toolbar: 

Click To 

 
Space Across. Moves three or more selected components so 
that the horizontal space between them is the same. 

 
Space Down. Moves three or more selected components so 
that the vertical space between them is the same.  

 
Same Width. Compares two or more selected objects and 
changes their width to match that of the last one selected. 

 
Same Height. Compares two or more selected objects and 
changes their height to match that of the last one selected. 

 
Same Size. Compares both the height and width of two or 
more selected objects and changes their dimensions to match 
that of the last one selected.  

Toolbar Nudge Bar  

Shows or hides the nudge buttons toolbar, as displayed below: 

 

The Nudge command enables you to move selected objects in single-pixel 
increments in any of four different directions. The buttons on the Nudge 
toolbar will only be available if there is at least one component selected on 
the active document. 
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Here is a complete list of buttons available in the Nudge Toolbar: 

Click To 

 
Nudge Up. Moves the selected component(s) up one pixel.  

 
Nudge Down. Moves the selected component(s) up one pixel.  

 
Nudge Left. Moves the selected component(s) left one pixel.  

 
Nudge Right. Moves the selected component(s) right one 
pixel.  

Toolbar Property Bar  

Shows or hides the property buttons toolbar, as displayed in the figure 
below: 

 

The Property Toolbar allows for quick access to the properties of the 
currently-selected object. 

Here is a complete list of buttons available in the Property Toolbar: 

Click To 

 
Properties. Displays the associated properties of the selected 
component(s). This button is only enabled if there is at least 
one component selected. 

 
Output. Shows or hides the output window  
 

 
Properties Window. Shows or hides the property window, 
displaying the related properties of the active selected 
component(s).  
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Toolbar Rotate Bar  

Shows or hides the rotate buttons toolbar, as displayed in the figure below: 

 

The buttons on the Rotate Toolbar will only be enabled if there is at least 
one selected component on the active document that supports rotation. 

Here is a complete list of buttons available in the Rotate Toolbar: 

Click To 

 
 

Rotate. Rotates the selected component(s) to any angle. Use 
Tools Angle Snap to restrict rotation to 15 degree 
increments. 

 
Rotate Left. Rotates the selected component(s) 90 degrees to 
the left.  

 
Rotate Right. Rotates the selected component(s) 90 degrees to 
the right.  

Toolbar Structure Bar  

Shows or hides the Structure Toolbar, as shown in the figure below: 

 

From the Structure Toolbar, you can group and ungroup objects, bring 
objects to the top, send them to back or move them up or down one layer. 

Here is a complete list of buttons available in the Structure Toolbar: 

Click To 

 
Group. Links the selected components together into a single 
collection. This button will only be available if more than one 
component is selected in the active document. 

 
Ungroup. Breaks apart a previously-grouped object. This 
button is only available when a grouped object is selected. 

 
Front. Brings the selected component(s) to the top of all the 
other components.  
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Back. Sends the selected component(s) back below all the 
other objects in the active document.  

 
Forward. Brings the selected component(s) up one level 
within the stack of objects on the active document. 

 
Backward. Sends the selected component(s) down one level 
within the stack of objects on the active document. 

Toolbar Zoom Bar  

Shows or hides the zoom toolbar, as displayed in the figure below: 

 

Here is a complete list of buttons available in the Zoom Toolbar: 

Click To 

 
Zoom. Activates the zoom tool. Clicking on an area of the 
current document will increase the magnification of that 
area. 

 
Current zoom percentage. This value can be set manually to 
get a specific, desired zoom.  

 
Zoom to Selection. Displays a view that shows all the 
components in the active document. 

 
Pan. Allows the user to move the active document in any 
direction. 

Toolbar Font Bar 

Use this command to show or hide the Font Toolbar, as displayed below: 

 

The controls on the Font Setting Toolbar will only be enabled if all of the 
selected components support font and alignment features. 
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Here is a complete list of buttons available in the Font Toolbar: 

Click To 

 
Style. Indicates the style of the selected 
component. Also can be used to apply 
a particular style to a component.  
Font. Indicates the current font of the 
selected component. Can also be used 
to change the font. 

 
Size. Indicates the font size of a component, and 
allows for the font size to be changed. 

 
Bold. Indicates if the selected font has a bold 
attribute assigned, or can be used to add or 
remove a bold attribute.  

 
Italic. Indicates if the selected font has an italic 
attribute assigned, or can be used to add or 
remove an italic attribute. 

 
Underline. Indicates if the selected font has an 
underline attribute assigned, or can be used to 
add or remove an underline attribute. 

 
Left Align. Indicates if the selected text object is 
left-justified, or can be used to change the 
current formatting to left-justified. 

 
Center Horizontally. Indicates if the selected 
text object is horizontally centered, or changes 
the current formatting to centered. 

 
Right Align. Indicates if the selected text object 
is right-justified, or can be used to change the 
current formatting to right-justified. 

 
Justify. Indicates if the selected text object is 
fully-justified, or can be used to change the 
current formatting to fully-justified. 

 
Top Align. Indicates if the selected text object is 
aligned with the top, or to change the current 
text positioning to top-aligned. 

 
Center Vertically Align. Indicates if the selected 
text object is aligned in the center, or to change 
the current text positioning to center-aligned. 

 
Bottom Align. Indicates if the selected text 
object is aligned with the bottom, or to change 
the current text positioning to bottom-aligned. 
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Status Bar  

Shows or hides the FormPort Designer status bar, as displayed in the 
following figure: 

 

The left area of the status bar describes the actions of menu items when 
you navigate through the menus using the arrow keys. Similarly, this area 
shows messages that describe the actions of toolbar buttons as you depress 
them and before releasing them.  

If after viewing the description of the toolbar button command you wish 
not to execute the command, then release the mouse button while the 
pointer is off the toolbar button. 

The right areas of the status bar indicate which of the following keys are 
latched down: 

Indicator Description 
CAP The Caps Lock key is currently latched down. 

NUM The Num Lock key is currently latched down. 

SCROLL The Scroll Lock key is currently latched down. 

Ruler  

Shows or hides the interface ruler.  

The ruler is used to show the unit of measurement in the active document, 
and to facilitate the creation of components with specific sizes. 

Grid  

Shows or hides the grid . 

The grid is useful for placing components at precise locations within a 
document. 
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Properties Window  

Shows or hides the Properties Window . 

The Properties Window is a dockable window that shows the properties of 
the selected component(s) in the active document. The properties shown in 
this window can either be changed directly, or through the traditional 
object-editing method. 

Zoom Zoom 

Activates the Zoom tool .  

After clicking on this command, the cursor will change to a magnifying 
glass. Left-clicking anywhere in the document will increase the 
magnification in 25% increments (to a maximum of 650%). Right-clicking 
will zoom out in 25% increments (to a minimum of 25%). You can zoom 
a specific region by clicking and dragging to define the area and then 
releasing the mouse button. 

Zoom Zoom 1:1 

Zooms the document to the normal scale of 100%.  

Zoom Zoom Custom...  

This command is used to zoom in 25% increments. 

When selected, the custom zoom dialog appears, as shown below: 

 

Select a value from the drop-down menu and then click on OK to initiate. 
Clicking on Cancel will abort the custom zoom procedure. 
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Zoom Zoom To Selection...  

This handy tool  determines the perfect zoom level necessary to fill the 
screen with the currently-selected object. 

NOTE: At least one object must be selected for this feature to be available. 

Zoom Fit to Width  

Use this command to set the zoom of the document so that all of the 
components are visible in the screen horizontally. 

Zoom Fit to Height  

Use this command to set the zoom of the document so that all of the 
components are visible in the screen vertically. 

Zoom Fit to Page  

Changes the view of the active document so that all of the components are 
visible on the screen both horizontally and vertically. 
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Page Menu 

From the Page menu, you can map both spool and CSV files, define page 
properties, add or remove pages and jump to a specific page in a multi-
page document. For detailed descriptions of these features, proceed to the 
following section. 

Spool Mapping Spool File Load Spool File… 

This command loads a spool file into the active document. Before you can 
insert a spool object, a spool files must first be loaded. This menu option is 
only available when no spool or CSV file is currently loaded in the active 
document. 

Once selected, a File Open dialog appears and asks for the name and 
location of the spool file to be loaded. 

Spool Mapping Spool File Reload Spool File 

This command reloads a previously-loaded spool file, and is only 
available if a spool file has already been loaded. 

Spool Mapping Spool File Unload Spool File  

This command unloads a previously-loaded spool file (and all associated 
spool objects) from the active document, and is only available if a spool 
file has already been loaded. 

Spool Mapping Spool File Display 'Copied' Area  

This command shows or hides the original spool data after it’s been copied 
and manipulated within FormPort Designer. This old data is normally 
displayed in blue text. 

 

 
This command can also be invoked by pressing the F3 key. 
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Spool Mapping Spool File Display 'Moved' Area  

This command shows or hides the original spool data after it’s been 
moved and manipulated within FormPort Designer. This old data is 
normally displayed in red text. 

 

 
This command can also be invoked by pressing the F2 key. 

Spool Mapping Spool File Display ‘Unused’ Area 

Use this command to show or hide the portions of the spool file that won’t 
be used in the final document. This data is normally displayed in gray text. 

 

 
This command can also be invoked by pressing the F4 key. 

Spool Mapping Spool File Spool File Options 

Use this command to change the spool file options, as shown in the 
following images: 

   

From these screens you can define the appearance, font and color of spool 
data within your document. 
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Spool Mapping CSV File Load CSV File 

Use this command to load a CSV file into the active document. Loading a 
CSV file is required before a CSV object can be inserted. 

This menu command will only be available if there is no spool file or CSV 
file already loaded into the document. 

 

NOTE: When loading a new CSV file, you must tell FormPort Designer 
which method was used to separate the data in the file (comma, semicolon, 
etc.). 

Spool Mapping CSV File Unload CSV File 

Use this command to unload a previously loaded CSV file (and all 
associated CSV objects) from the active document. This command is only 
available when a CSV file has already been loaded. 
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Page Control Insert Page 

Use this command to insert new empty pages into the active document. 

 
Multiple pages can be added either before or after the current page. 

Page Control Remove Page  

Use this command whenever you need to remove a page or a specific 
number of pages (and all the components currently on those pages) from 
the active document.  

 

Page Control Go to Page  

Use this command to go directly to a specific page number within the 
active document. 

 

Enter the page number in the Page number field and then press OK to go 
to their. 
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Page Setup 

Use this command to modify the properties associated with the current 
page of the active document. These settings can be the same for every 
page in a multi-page document, or completely unique for each page. 

The image below illustrates both tabs of the Page Setup property sheet: 
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Insert Menu 

From this menu you can insert external data files into your FormPort 
Designer form. 

Properties 

Once an object has been inserted into a document, various attributes and 
properties can be assigned so as to further define its appearance and 
function. This section describes each of these properties. 

NOTE: The properties available are dependent on the type of object to 
which they’re being applied. 

General 

General properties are displayed on this page. 

 

This page contains the information about the component name, component 
type and component position and size.  

This page is for informational purposes only, and other than the Name 
field, these values can’t be edited directly. 
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Line 

This page contains the information related to the line settings of 
components with borders. 

 

Color  
This button determines the border color of the component. 
Click on it to see a popup window and other color choices. 

No Line  
If you wish the component’s border to be invisible, check 
this option. 

Style  
The style of single-pixel borders can be selected from this 
list. If the current border is thicker than one pixel, this list 
will be grayed-out. 

Width  
The width of solid borders can be determined through this 
list. If the border is using a style other than solid, this list 
will be grayed-out and not available. 
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Line Spacing 

This page contains the information related to the field spacing. Enter the 
correct line spacing for the field object in the related edit box.  
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Fill 

This page contains the information related to the manner in which the 
component has been filled. 

 

Foreground Color  
This color button indicates the foreground color of both 
solid and non-solid hatch patterns used to fill components. 
Click on the button and select the desired color from the 
popup window. This option isn’t available when 
Transparent Fill is checked. 

Background Color  
This color button indicates the background color in hatch 
patterns. If the current fill is solid, this color isn’t used. 
Like foreground color, this option isn’t available when 
Transparent Fill is checked. 

Transparent Fill  
This option turns the non-border region of components 
transparent. 

Hatch  
Displays the patterns available for components that support 
the fill attribute. Fills can be either solid or a number of 
two-color patterns.  
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Round Corners 

This page contains the information related to the rounded corners of the 
round rectangle object.  

 

Top Left  
If checked, indicates the Top Left corner will be rounded. 

Top Right  
If checked, indicates the Top Right corner will be rounded.  

Bottom Left  
If checked, indicates the Bottom Left corner will be 
rounded.  

Bottom Right  
If checked, indicates the Bottom Right corner will be 
rounded.  

Percentage  
Determines the amount of curve to apply to the edges of the 
object. Both of these values are linked; changing one 
automatically changes the other. 
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Font 

This page contains the information related to the font properties of 
supported components. 

 

Font Name  
This list indicates the currently-assigned font as well as the 
others available.  

Font Style  
Indicates the current style as well as the other available 
styles for assignment. 

Font Size  
Shows the current font size and a list of all the sizes 
available. 

Underline  
Selecting this checkbox will add an underline to the current 
text object.  

Strike-Out  
Selecting this checkbox will add a line through the current 
text object. 
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Text Color  
This button defines the color of the current text object. 
Click on it to display a popup window with other color 
selections. Most text objects are black by default. 

Preview  
This area provides a sample of what the resulting text 
object will look like. 

After making any changes, click on either OK or Apply to accept them, or 
Cancel to revert the text object back to what it was. 

Image Properties 

This page allows you to define the resolution of an imported image. 

 

Simply select the desired resolution from the drop-down list and choose 
OK. 

NOTE: Increasing the resolution of an image will make it appear to shrink. 
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Barcode 

This page contains the information related to the barcode settings. 

 

Barcode Type  
Indicates the type of the current barcode object. This value 
can be changed through the drop-down menu.  

Bar Height  
Specifies the height of the barcode.   

Narrow Bar Width  
Determines the width of the barcode.  

Prefix  
Barcode prefixes can be entered in this field.  

Suffix  
Barcode suffixes can be entered here..  

Description  
Enter a user-defined description of the current barcode 
here.  

Bar Width Ratio  
Sets the barcode width ratio to either 2, 2.5 or 3.  
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Calculate Check Digit  
Should be checked to enable the calculate check digit 
feature. 

Print Check Digit  
Check to enable the print check digit option. 

NOTE: Print Check Digit with be grayed-out unless the Calculate 
Check Digit option is checked.  

Text Position  
Choose between aligning text along the top or bottom of 
the barcode.  

Spool Info 

This page contains the information related to the spool objects settings. 

 

Action  
This section indicates how the spool data was manipulated 
after being inserted. This option is only available at 
insertion time and is only shown for informational 
purposes. 

Start at column #  
Displays the starting column number of the selected text 
area.  
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Start at line #  
Displays the starting line number of the selected text area.  

Number of characters  
Displays the number of characters in the widest available 
line in the selected text area.  

Number of lines  
Displays the maximum number of lines that will appear in 
the spool object.  

Line Spacing  
Displays the space between each line of the spool object in 
LPI (Line-Per-Inch) units. The two buttons (labeled 6 LPI 
and 8 LPI) are simply shortcut buttons used to enter the 
specified values automatically. 

Formula 

This page contains information about any formulas assigned to the 
selected object. 

 

Operators  
Displays the list of operators. Double-click on any of these 
to append them to the object’s formula. 
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Functions  
Displays the list of functions. Double-click on any of these 
to append them to the object’s formula. 

Fields  
Displays the list of fields in the active document. Double-
click any of these to append them to the object's formula.  

Formula  
Displays the object’s final formula. This formula can also 
be entered or edited manually by typing in the Formula 
edit box.  

Calculation & Validation  
This part of the page will only be visible if the object 
supports both the Calculation Formula and Validation 
Formula. If present, ensure the correct value is set.  

CSV Field 

This page contains the information related to the CSV files that have been 
mapped and inserted into the document. 

 

Action  
This section indicates how the CSV data was manipulated 
after being inserted. This option is only available at 
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insertion time and is shown here only for informational 
purposes. 

Fields  
This drop-down menu lists the separated objects from the 
first line of the CSV file. Choose the one you wish to 
display. 

Line Spacing  
Displays the space between each line of the spool object in 
LPI (Line-Per-Inch) units. The two buttons (labeled 6 LPI 
and 8 LPI) are simply shortcut buttons used to enter the 
specified values automatically.  

Date Format 

This page allows you to choose a specfic date format. 

 

Select a Format and Language from the drop-down menu and then click 
on OK. 
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Time Format 

This page allows you to pick a specific time format. 

  

Select the desired time Format and then click on OK to accept. 

Page Number 

This allows you to define the look of the page number object. 

 

Enter a Prefix and Suffix into the appropriate edit field and then click OK 
to accept. 
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Numeric 

This page contains the information related to the numeric field. 

 

The following settings are available through the numeric page: 

Symbol  
Defines the currency symbol to display with monetary 
values.  

Symbol Position  
Indicates where the monetary symbol should be placed in 
relation to the amount.  

Negative Symbol  
Allows you to specify where a negative symbol (if used) 
will be placed in relation to the amount. 

Thousand Separator   
Enter the character you’d like to serve as a separator for 
values in excess of a thousand. 

Decimal Separator  
Enter the character you’d like separate whole and decimal 
numbers. 
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Decimal Number  
Specify the number of digits to follow the decimal 
separator symbol. 

Leader  
Enter a Leader string of up to 12 characters.  

Trailer  
Enter a Trailer string of up to 12 characters.  

Remove Insignificant Zeros  
Check this checkbox if you wish the insignificant zeros in 
the numbers to be removed from the monetary amounts.  
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Spool Text 

Selecting this command or icon  inserts a spool text component into the 
active page. This command is only active if there is a spool file currently 
loaded into the active document. 

The Spool Text component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, Spool Info Property Page, Formula Property Page 

Spool Image 

Selecting this command or icon  inserts a spool image component into 
the active page. This command is only active if there is a spool file 
currently loaded into the active document. 

The Spool Image component supports the following properties: 

General Property Page, Spool Info Property Page, Image Property Page, 
Formula Property Page 

Spool Barcode 

Selecting this command or icon  inserts a spool barcode component into 
the active page. This command is only active if there is a spool file 
currently loaded into the active document. 

The Spool Barcode component supports the following properties: 

General Property Page, Font Property Page, Spool Info Property Page, 
Barcode Property Page, Formula Property Page 

CSV Spool Text 

Selecting this command or icon  inserts a CSV spool text component 
into the active page. This command is only active if there is a CSV file 
currently loaded into the active document. 

The CSV Spool Text component supports the following properties: 
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General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, CSV Field Property Page, Formula Property Page 

CSV Spool Image 

Selecting this command or icon  inserts a CSV spool image component 
into the active page. This command is only active if there is a CSV file 
currently loaded into the active document. 

The CSV Spool Image component supports the following properties:  

General Property Page, Spool Info Property Page, Image Property Page, 
CSV Field Property Page, Formula Property Page 

CSV Spool Barcode 

Selecting this command or icon  inserts a CSV spool barcode 
component into the active page. This command is only active if there is a 
CSV file currently loaded into the active document. 

The CSV Spool Barcode component supports the following properties: 

General Property Page, Font Property Page, Spool Info Property Page, 
Barcode Property Page, CSV Field Property Page, Formula Property 
Page 

Field 

Selecting this command or icon  inserts a field component into the 
active page. Although the default border for this component is transparent, 
a virtual red border appears around the field object to indicate the 
bounding rectangle and assist placement. 

The Field component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, Line Spacing Property Page, Formula Property Page 
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Date Field 

Selecting this command inserts a date field component into the active 
page. Although the default border for this component is transparent, a 
virtual red border appears around the field object to indicate the bounding 
rectangle and assist placement. 

The Date Field component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, Line Spacing Property Page, Date Format Property Page 

Time Field 

Selecting this command inserts a time field component into the active 
page. Although the default border for this component is transparent, a 
virtual red border appears around the field object to indicate the bounding 
rectangle and assist placement. 

The Time Field component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, Line Spacing Property Page, Time Format Property Page 

Page Number Field 

This command inserts a page number field component into the active 
page. Although the default border for this component is transparent, a 
virtual red border appears around the field object to indicate the bounding 
rectangle and assist placement. 

The Page Number Field component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, Line Spacing Property Page, Page Number Property Page 

Numeric Field 

This command inserts a numeric field component into the active page. 
Although the default border for this component is transparent, a virtual red 
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border appears around the field object to indicate the bounding rectangle 
and assist placement. 

The Numeric Field component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, Line Spacing Property Page, Numeric Property Page, 
Formula Property Page 

Rich Text 

Choosing this command or icon  inserts a text component field into the 
active page. After insertion, a Rich Text component automatically goes 
into edit mode. 

The Rich Text component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Font 
Property Page, Line Spacing Property Page, Formula Property Page 

Image 

Choosing this command or icon  inserts an external image component 
into the active page.  

The Image component supports the following properties: 

General Property Page, Image Property Page, Formula Property Page 

Barcode 

Use this command or icon  to insert a barcode component into the 
active page.  

The Barcode component supports the following properties: 

General Property Page, Font Property Page, Barcode Property Page, 
Formula Property Page 
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Line 

Use this command or icon  to insert a line component into the active 
page.  

The Line component supports the following properties: 

General Property Page, Line Property Page, Formula Property Page 

Rectangle 

Selecting this command or icon  inserts a rectangle component into the 
active page.  

The Rectangle component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Formula 
Property Page 

Round Rectangle 

Use this command or icon  to insert a round rectangle component into 
the active page.  

The Round Rectangle component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Round 
Corners Property Page, Formula Property Page 

Ellipse 

Selecting this command or icon  inserts an ellipse component into the 
active page.  

The Ellipse component supports the following properties: 

General Property Page, Line Property Page, Fill Property Page, Formula 
Property Page 
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Format Menu 

The Format menu enables you to modify the look of text objects. 

Font 

Use this command to display and set the font attributes of the currently-
selected text object(s). This command will open the component property 
sheet, with the Font property page tab selected, as shown below: 

 

Justification Left 

Use this command to align the left edge of the currently-selected 
component(s). 

Justification Center Horizontally 

Use this command to center the currently-selected component(s). 
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Justification Right  

Use this command to align the right edge of the currently-selected 
component(s). 

Justification Justify 

Use this command to align both the left and right edges of the currently-
selected component(s). 

Justification Top 

Use this command to align the text in the currently-selected text 
component against the top border of the object. 

Justification Center Vertically 

Use this command to vertically center the text in the currently-selected 
text component within the borders of the object. 

Justification Bottom 

Use this command to align the text in the currently-selected text 
component against the bottom border of the object. 
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Style… 

Use this command to open the Style Manager dialog window. 

NOTE: You must have a text object selected for the Style… command to 
be enabled. 

 

After you’ve modified the appearance of a text object, you can give a 
name to that look and save it in the style manager. This style can then be 
applied to other text objects to save time and ensure a consistent look. 
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Tools Menu 

Under the Tools menu, you can further refine and optimize the 
components that make up your form. 

Field Filling Order… 

Through this dialog window, you can specify the order in which the text 
fields will be filled. 

 

NOTE: There must be at least two fields in the document for this option to 
be available. 

To change the order, simply select a field and then use either the up or 
down arrow keys to move it around the list. Click on OK to accept the new 
order, or Cancel to revert back to the original order. 
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Group Resize… 

This feature allows you to resize multiple objects in a single step. Resizing 
can be performed horizontally, vertically or both dimensions at once. 

 

NOTE: At least two objects must be selected for this command to be 
enabled. 

Group Align 

Align Top 

Use this command or toolbar icon  to move the selected object(s) into 
alignment with the topmost portion of the last selected object. At least two 
objects must be selected for this command to be available. 

Align Middle 

Use this command or toolbar icon  to move the selected object(s) into 
horizontal alignment with the last selected object. At least two objects 
must be selected for this command to be available. 

Align Bottom 

Use this command or toolbar icon  to move the selected object(s) into 
alignment with the bottommost portion of the last selected object. At least 
two objects must be selected for this command to be available. 
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Align Left 

Use this command or toolbar icon  to move the selected object(s) into 
alignment with the leftmost portion of the last selected object. At least two 
objects must be selected for this command to be available. 

Align Center 

Use this command or toolbar icon  to move the selected object(s) into 
vertical alignment with the last selected object. At least two objects must 
be selected for this command to be available. 

Align Right 

Use this command or toolbar icon  to move the selected object(s) into 
alignment with the rightmost portion of the last selected object. At least 
two objects must be selected for this command to be available. 

Group Layout 

Space Across 

Use this command or toolbar icon  to equally space three or more 
selected objects horizontally on the current page. 

Space Down 

Use this command or toolbar icon  to equally space three or more 
selected objects vertically on the current page. 

Same Width 

Use this command or toolbar icon  to change the width of the selected 
components so that they match the width of the last selected object. At 
least two objects must be selected for this command to be available. 

Same Height 

Use this command or toolbar icon  to change the height of the selected 
components so that they match the width of the last selected object. At 
least two objects must be selected for this command to be available. 
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Same Size 

Use this command or toolbar icon  to change the both the height and 
width of the selected components so that they match the width of the last 
selected object. At least two objects must be selected for this command to 
be available. 

Group 

Group Command 

Use this command or toolbar icon  to group selected components into a 
single object. Grouped objects can easily be ungrouped later if needed. 
This button is only available if there is more than one selected component 
in the active document. 

Ungroup 

Use this command or toolbar icon  to ungroup the selected group 
component. This button is only available after you select a group in the 
active document. 

Bring to Front 

Use this command or toolbar icon  to bring the selected component(s) 
to the topmost layer of the object stack. You must select at least one object 
for this command to be available. 

Send to Back 

Use this command or toolbar icon  to send the selected component(s) to 
the bottommost layer of the object stack. You must select at least one 
object for this command to be available. 

Bring Forward 

Use this command or toolbar icon  to elevate the selected component(s) 
up one level in the object stack. You must select at least one object for this 
command to work, and it ceases to have an effect once the object has 
reached the top of the stack. 
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Send Backward 

Use this command or toolbar icon  to send the selected component(s) 
down one level in the object stack. You must select at least one object for 
this command to work, and it ceases to have an effect once the object has 
reached the bottom of the stack. 

Nudge 

The Nudge command moves the selected object(s) a single pixel in the 
direction you specify. 

Nudge Up 

Use this command or toolbar icon  to move the selected component(s) 
up one pixel. 

Nudge Down 

Use this command or toolbar icon  to move the selected component(s) 
down one pixel. 

Nudge Left 

Use this command or toolbar icon  to move the selected component(s) 
left one pixel. 

Nudge Right 

Use this command or toolbar icon  to move the selected component(s) 
right one pixel. 

Rotate 

Free Rotation 

Select this icon  to freely rotate the current object. Using angle snap 
constrains free rotation to increments of 15°. 

Left 90 Degrees 

Click this icon  to rotate the selected object 90° to the left. 
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Right 90 Degrees 

Click this icon  to rotate the selected object 90° to the right. 

Snap to Grid Command 

Use this command or toolbar icon  to enable or disable the Snap to 
Grid feature for components on the active document page. Grid settings 
can be customized through the Tools Grid Properties command. 

Angle Snap Command 

Use this command to activate or deactivate the Angle Snap feature used 
when rotating objects. When enabled, objects rotate in 15° increments. 
Grid settings can be customized through the Tools Grid Properties 
command. 

Grid Properties… 

Use this command to open the Grid Properties dialog. This dialog will 
give the ability to set the grid properties. 

 

Auto Select Tools 

Enable this command to automatically select all inserted or drawn objects. 
When off, you must manually select new objects before modifying their 
properties. 
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Options 

Through this menu item you can customize how some functions of 
FormPort Designer behave. 

 

In addition, you can specify whether or not FormPort Designer 
automatically complies documents prior to displaying a print preview or 
before printing the document. You can also set how many recent files 
appear in the File menu history list (up to a maximum of 16) and set the 
number of undo levels (50 maximum). 

NOTE: Setting excessive undo levels could impact system performance, 
and should always be used with caution. 
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Window Menu 

The Window menu contains the items listed below: 

Cascade 

This command arranges multiple opened windows in an overlapped 
fashion. 

Tile 

Arranges multiple opened windows in a non-overlapped fashion. 

Arrange Icons 

Arrange the icons for minimized windows at the bottom of the main 
window.  If there is an open document window at the bottom of the main 
window, then some or all of the icons may not be visible since they’ll be 
underneath this document window. 

Close All 

Use this command to close all of the currently-open documents. If there 
are any unsaved changes in any of the documents, the Save dialog will 
open and prompt you to save. 

Open Files List 

The application displays a list of currently-open document windows at the 
bottom of the Window menu. A check mark appears in front of the 
document name of the active window. Select any document from this list 
to make it active.  
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Help Menu 

The Help menu contains links to various assistance resources. 

Contents 

Use this command to open the online help documentation's table of 
contents. 

Register FormPort Designer… 

This menu item launches a dialog box allowing you to register FormPort 
Designer. 

 

To register the product, perform the following procedure: 

1. Copy the Identification Key and Email it to register@capellatech.com 
with a valid return address. 

2. When you receive the Validation Key, enter it into the FormPort 
Designer Registration dialog and click on the Register button. 

FormPort Designer is now registered and ready to use without restrictions. 

Technical Support 

Contact information for technical support is displayed by selecting this 
menu item. 
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About 

Use this command to display a window with version and copyright 
information. 


